La Función y, o en Excel Con Ejemplo

  • Published on
    21-Dec-2015

  • View
    9

  • Download
    5

Embed Size (px)

DESCRIPTION

Ejemplo

Transcript

La funcin Y en Excel

La funcin Y en Exceles una funcin lgica que nos permitir evaluar varias expresiones lgicas y saber si todas ellas son verdaderas. Ser suficiente con que cualquiera de las expresiones sea falsa para que el resultado de la funcin tambin sea FALSO.

Sintaxis de la funcin Y

Los argumentos dela funcin Y en Excelson los siguientes:

Valor_lgico1(obligatorio): Expresin lgica que ser evaluada por la funcin.

Valor_lgico2(opcional): Expresiones lgicas a evaluar, opcional hasta un mximo de 255.

La funcin Ysolamente regresar el valor VERDADERO si todas las expresiones lgicas evaluadas son verdaderas. Bastar con que una sola expresin sea falsa para quela funcin Ytenga un resultado FALSO.

Ejemplos de la funcin Y

Observa la siguiente frmula y te dars cuenta de que todas las expresiones son verdaderas:

=Y(5=5, 16)

Ya que todas las expresiones son verdaderas,la funcin Ydevolver tambin el valor VERDADERO.

Ahora agregar una cuarta expresin que ser falsa: 77. Observa cmo ser suficiente para quela funcin Ydevuelva el valor FALSO:

Argumentos de la funcin Y

Cada un de los argumentos dela funcin Ypuede ser una expresin lgica como en los ejemplos anteriores pero tambin puede ser una funcin de Excel que devuelva un valor FALSO o VERDADERO.

Observa el siguiente ejemplo donde he combinado una expresin lgica con la funcin ES.PAR y la funcin ES.IMPAR las cuales evalan un nmero para indicarnos si es par o impar respectivamente.

Ya que tanto la expresin lgica como las funciones son evaluadas como verdaderas, entoncesla funcin Ynos un resultado VERDADERO. Ahora observa como al cambiar solamente el argumento de la funcin ES.IMPAR con el nmero 6 (en lugar de 5), causar quela funcin Ynos devuelva el valor FALSO.

Si alguna vez necesitas estar seguro de que todo un grupo de expresiones lgicas sean verdaderas,la funcin Y en Excel ser una excelente opcin para hacerlo.

La funcin SI es una de las que mas se usan para el anidamiento ya que su estructura es muy adecuada para esto:

1. En el parmetro 1 hay que poner una frmula lgica, un anidamiento con funciones lgicas o la propia funcin si actuando como funcin lgica.

2. En loa parmetros 2 y 3 se pueden anidar una multitud de funciones, como funciones lgicas, lafuncion si() actuando como funcin condicional o lgica etc.

Ahora vamos a ver un un ejemplo relativamente simple de la situacin del punto 1.

Una empresa quiere promover a una nueva seccin a los empleado que cumplan con las siguientes condiciones :

1. Pertenecer al turno maana.

2. Ser de la categora 1 o que su sueldo sea menor o igual a 7.000$.

Para esto cuenta con la siguiente tabla que debe ser completada; donde los turnos son M,T ,N ,correspondientes a maana, tarde y noche respectivamente y las secciones van de 1 a 4

Que se resuelve utilizando la frmula

=SI(Y(O(E2=4;D2